Demo – EMC VxRail software upgrade from v4.0.310 to v4.5.0 (Quanta)

This demo describes the steps required to perform a data-in-place upgrade on a VxRail Appliance G410 from v4.0.310 to v4.5.0.

NOTE: This demo is using the internal vCenter server.

As a requirement of this upgrade, vCenter must be running at 6.5 U1. If using internal vCenter, the upgrade script will automatically upgrade internal vCenter to 6.5 U1. If using an external vCenter, the Customer must be running vCenter to v6.5 U1 prior to the VxRail upgrade or the upgrade script will fail.

Preparation

  1. A temporary IP Address on the same subnet needed to upgrade vCenter Server.
  2. VxRail Software upgrade package “VXRAIL_COMPOSITE-4.5.0-6607744.zip“, you can download it at http://support.emc.com.
  3. Make sure the running software of VxRail Appliance is v4.0.31.
  4. Make sure the v4.0.310 VxRail appliance is in a healthy state.

Software Upgrade Process

  1. Select Internet or Local Upgrade.
  2. After copy upgrade package to VxRail, upgrade wizard will unpack the Composite Upgrade Bundle.
  3. Upgrade VxRail Manager first
  4. Upgrade vCenter and Platform Services Controller (only for the internal VC/PSC)
    • For internal vCenter (prepare one temp IP address for VC upgrade).
    • Deploys new 6.5 PSC and imports the running settings.
    • Deploys new 6.5 VC and imports the running settings.
  5. Upgrade ESXi (installs necessary VIBs and FW as required)
  6. Upgrade vDS and VSAN on-disk format from v3 to v5.

VxRail Software Upgrade

Login into VxRail Manager, go to CONFIG page > System tab. Click Local Upgrade button.

Choose VXRAIL_COMPOSITE-4.5.0-6607744.zip, and then click Open to select.

The download progress can be monitored on the screen.

Click the Continue button to start the upgrade.

Input the usernames and passwords, and input fields will differ depending on whether you are using an external vCenter or internal vCenter. Click Submit to continue.

NOTE: If DRS is not enabled, the upgrade script will prompt you to manually migrate VMs from each affected host.

Following the pop up window, input user names and passwords, click Submit button.

The upgrade progress can be monitored on the screen.

You need to input a Temporary network configuration, DNS configuration and ESXi Server credentials. Input the required information and click Continue to proceed with the upgrade.

NOTE: The temporary IP is used for the new VCSA or PSC when deploying a new VCSA or PSC virtual machine during the upgrade of VCSA. The IP must not be in use and must be in the same network segment with VxRail Manager. It does not need to be added in DNS lookup table. The two ESXi host server credentials are used for new and legacy VCSA and PSC.

Wait for the upgrade to complete, and then click the Refresh button to refresh the VxRail Manager GUI. It may take several minutes for the GUI to update. Once the Refresh has completed, click Installed Versions to verify the VxRail component versions.

Make sure the VxRail appliance is in a healthy state. On the CONFIG page under the General tab, select the Diagnostic button under System Diagnostics to verify the VxRail cluster health status.

Finally the software upgrade is successfully completed. Log out of VxRail Manager.

Advertisements

12 thoughts on “Demo – EMC VxRail software upgrade from v4.0.310 to v4.5.0 (Quanta)

Add yours

  1. Hi, I have a question about the DNS. Currently We have an internal DNS, we have checked and we see that vxrail manager, esx server’s, vCenter and PSC have set vCenter IP as name server (vcenter is running a dnsmasq service). Is it a valid configuration? or, Do we need to move DNS server an external DNs before upgrade?

  2. Hi, I have a question about the DNS. Currently We have an internal DNS, we have checked and we see that vxrail manager, esx server’s, vCenter and PSC have set vCenter IP as name server (vcenter is running a dnsmasq service). Is it a valid configuration? or, Do we need to move DNS server to an external DNS before upgrade?

      1. is there any guidance on how to accomplish this. Dell/EMC can’t seem to answer the question on how to move from using the DNSMASQ service to using external dns.

  3. I wasn’t able to upgrade the VxRAIL Appliance to 4.5.x from 4.0.x as the minimum requirement for the Host in Cluster is 4.
    If I have a Cluster of 3 Host how can I upgrade to 4.5.x ?

    1. Hi Kunal,

      The upgrade pre-check failures occur if there are only 3 nodes are running VxRail Cluster. You need to bypass this pre-checks then can upgrade the software package. However this upgrade procedure can be executed by DellEMC support or partner, I suggest that contact the DellEMC support team for this upgrade.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

Create a free website or blog at WordPress.com.

Up ↑

%d bloggers like this: